USF Websites are Not Loading Properly
Incident Report for University of San Francisco
Resolved
Web services was able to work with the vendor to implement a fix. The issue has been fully resolved. Thank you for your patience.
Posted Sep 14, 2023 - 16:07 PDT
Investigating
We received reports that some USF websites are not loading properly. Our Web Services team is investigating the issue. Thank you.
Posted Sep 14, 2023 - 11:16 PDT
This incident affected: Website(s).