Slack is experiencing a service degradation
Incident Report for University of San Francisco
Resolved
The issue with Slack has been resolved. Thank you for your patience.
Posted Jan 24, 2024 - 11:54 PST
Investigating
Slack workflows is currently experiencing a service degradation affecting staff and faculty at USF. Some messaging may be delayed. We will monitor and update if this turns into a full outage.
Posted Jan 24, 2024 - 09:18 PST
This incident affected: Slack.