Canvas degraded for Xfinity Users
Incident Report for University of San Francisco
Resolved
The canvas issue has been resolved.
Posted Mar 05, 2024 - 16:05 PST
Identified
Cavas is reporting that this issue is impacting Xfinity customers trying to access Canvas.
Posted Mar 05, 2024 - 13:04 PST
Investigating
We are currently investigating this issue.
Posted Mar 05, 2024 - 13:03 PST
This incident affected: Canvas.